New Search

RHSA-2008:0561 -- ruby security update (Moderate)

oval:org.mitre.oval:def:28980

Updated ruby packages that fix several security issues are now available for Red Hat Enterprise Linux 4 and 5. This update has been rated as having moderate security impact by the Red Hat Security Response Team. Ruby is an interpreted scripting language for quick and easy object-oriented programming. Multiple integer overflows leading to a heap overflow were discovered in the array- and string-handling code used by Ruby. An attacker could use these flaws to crash a Ruby application or possibly execute arbitrary code with the privileges of the Ruby application using untrusted inputs in array or string operations. (CVE-2008-2376 CVE-2008-2662 CVE-2008-2663 CVE-2008-2725 CVE-2008-2726)

Family:
unix
Status:
ACCEPTED
Platform(s):
  • CentOS Linux 5
  • Red Hat Enterprise Linux 4
  • Red Hat Enterprise Linux 5
Class:
patch
Reference(s):
  • RHSA-2008:0561
  • CESA-2008:0561-CentOS 5
  • CVE-2008-2376
  • CVE-2008-2662
  • CVE-2008-2663
  • CVE-2008-2664
  • CVE-2008-2725
  • CVE-2008-2726
Product(s):
  • ruby