New Search

RHSA-2008:0597 -- firefox security update (Critical)

oval:org.mitre.oval:def:29066

Updated firefox packages that fix various security issues are now available for Red Hat Enterprise Linux 5. This update has been rated as having critical security impact by the Red Hat Security Response Team. The nspluginwrapper package has been added to this advisory to satisfy a missing package dependency issue. Mozilla Firefox is an open source Web browser. An integer overflow flaw was found in the way Firefox displayed certain web content. A malicious web site could cause Firefox to crash or execute arbitrary code with the permissions of the user running Firefox. (CVE-2008-2785) A flaw was found in the way Firefox handled certain command line URLs. If another application passed Firefox a malformed URL it could result in Firefox executing local malicious content with chrome privileges. (CVE-2008-2933) All firefox users should upgrade to these updated packages which contain Firefox 3.0.1 that corrects these issues.

Family:
unix
Status:
ACCEPTED
Platform(s):
  • CentOS Linux 5
  • Red Hat Enterprise Linux 5
Class:
patch
Reference(s):
  • RHSA-2008:0597
  • CESA-2008:0597-CentOS 5
  • CVE-2008-2785
  • CVE-2008-2933
  • CVE-2008-3198
Product(s):
  • xulrunner
  • firefox
  • devhelp
  • nspluginwrapper
  • yelp