New Search

RHSA-2009:0345 -- ghostscript security update (Moderate)

oval:org.mitre.oval:def:29171

Updated ghostscript packages that fix multiple security issues are now available for Red Hat Enterprise Linux 3 4 and 5. This update has been rated as having moderate security impact by the Red Hat Security Response Team. Ghostscript is a set of software that provides a PostScript(TM) interpreter a set of C procedures (the Ghostscript library which implements the graphics capabilities in the PostScript language) and an interpreter for Portable Document Format (PDF) files. Multiple integer overflow flaws which could lead to heap-based buffer overflows as well as multiple insufficient input validation flaws were found in Ghostscript's International Color Consortium Format library (icclib). Using specially-crafted ICC profiles an attacker could create a malicious PostScript or PDF file with embedded images which could cause Ghostscript to crash or potentially execute arbitrary code when opened by the victim. (CVE-2009-0583 CVE-2009-0584) All users of ghostscript are advised to upgrade to these updated packages which contain a backported patch to correct these issues.

Family:
unix
Status:
ACCEPTED
Platform(s):
  • CentOS Linux 3
  • Red Hat Enterprise Linux 5
  • Red Hat Enterprise Linux 3
  • Red Hat Enterprise Linux 4
Class:
patch
Reference(s):
  • RHSA-2009:0345
  • CESA-2009:0345-CentOS 3
  • CVE-2009-0583
  • CVE-2009-0584
Product(s):
  • ghostscript