New Search

SQL Server remote code execution vulnerability - CVE-2015-1762 (MS15-058)

oval:org.mitre.oval:def:29485

Microsoft SQL Server 2008 SP3 and SP4 2008 R2 SP2 and SP3 2012 SP1 and SP2 and 2014 when transactional replication is configured does not prevent use of uninitialized memory in unspecified function calls which allows remote authenticated users to execute arbitrary code by leveraging certain permissions and making a crafted query as demonstrated by the VIEW SERVER STATE permission aka "SQL Server Remote Code Execution Vulnerability."

Family:
windows
Status:
ACCEPTED
Platform(s):
  • Microsoft Windows Server 2008 R2
  • Microsoft Windows 7
  • Microsoft Windows Server 2012
  • Microsoft Windows Server 2012 R2
  • Microsoft Windows Server 2008
  • Microsoft Windows 8.1
  • Microsoft Windows 8
  • Microsoft Windows XP
  • Microsoft Windows Vista
  • Microsoft Windows Server 2003
Class:
vulnerability
Reference(s):
  • CVE-2015-1762
Product(s):
  • Microsoft SQL Server 2008
  • Microsoft SQL Server 2014
  • Microsoft SQL Server 2012
  • Microsoft SQL Server 2008 R2