New Search

Vulnerability in pl\php ADD-ON in PostgreSQL version less than or equal to 9.0

oval:org.mitre.oval:def:6645

The PL/php add-on 1.4 and earlier for PostgreSQL does not properly protect script execution by a different SQL user identity within the same session which allows remote authenticated users to gain privileges via crafted script code in a SECURITY DEFINER function a related issue to CVE-2010-3433.

Family:
windows
Status:
ACCEPTED
Platform(s):
  • Microsoft Windows 7
  • Microsoft Windows 2000
  • Microsoft Windows Server 2008
  • Microsoft Windows XP
  • Microsoft Windows Vista
  • Microsoft Windows Server 2003
Class:
vulnerability
Reference(s):
  • CVE-2010-3781
Product(s):
  • PostgreSQL